In this article:
Problem
When a user is trying is set a password on the SecurityScorecard Platform, the following error occurs "We have encountered an error. Please check you email for more information or contact support". After verification, no email has reached them.
Cause
One of the cause for this error to occur is because the Organization of the user has SSO enabled. Users need to authenticate through their Organization's IdP and not locally via SecurityScorecard Platform. In this case, SecurityScorecard Platform will not allow the user to set its passwords. Any access request should be addressed to the Organization SAML Administrator.
How to log in using SSO
Step 1: Visit platform.securityscorecard.io and click on Log in with SSO button
Step 2: Enter your SSO enabled email address and click on Continue:
Step 3: You will be taken to your IdP as configured by your Organization where you can enter your credentials as setup by your organization.
See Also
https://support.securityscorecard.com/hc/en-us/articles/360062524891-FAQ-SAML-SSO